Pago con redsys no genera pedido

Pagos, Módulos de Envío, imágenes etc...
Reglas del Foro
reglas-del-foro-t61.html

Realizad siempre una copia de seguridad antes de realizar modificaciones. Realizad las modificaciones bajo vuestra responsabilidad, comercianos no sera responsable en ningun caso de los errores o perdidas que pudieran producirse.
tiopardi
Mensajes: 8
Registrado: hace 5 years
URL de la tienda: www.ortored.es
Version oscommerce: 2.3.4
Servidor: Debian

Pago con redsys no genera pedido

Mensaje por tiopardi » hace 5 years

Hola familia!!! he releeido todos los post sobre el tema pero no consigo encontrar solucion, resulta que con el modulo redsys que tengo instalado en la web cuando realizo el pago correctamente me devuelve a la web pero lo curioso es que la cesta se vacia pero no se genera el pedido.
He revisado la configuracion SSL como indican en los post pero nada....

¿alguien me puede indicar que puedo probar?


Muchisimas gracias!!!

figue
Mensajes: 875
Registrado: hace 8 years
URL de la tienda: www.mueblesdeforja.es
Version oscommerce: 2.3.3
Servidor: Linux
Ubicación: Córdoba
Contactar:

Re: Pago con redsys no genera pedido

Mensaje por figue » hace 5 years

El archivo que graba los pedidos es el checkout_proccess.php y este te redirije al checkout_success.php

Mira la url de retorno que has puesto y revisa la instalacion en el caso de que toque esos archivos o incluya alguno que los reemplace.


*** El 99% de la veces es fallo del modulo, que no esta bien o es antiguo, asi que lo mas facil es probar con otro.

tiopardi
Mensajes: 8
Registrado: hace 5 years
URL de la tienda: www.ortored.es
Version oscommerce: 2.3.4
Servidor: Debian

Re: Pago con redsys no genera pedido

Mensaje por tiopardi » hace 5 years

hola!
He generado un nuevo pedido y este me redirije hacia redsys_process.php
Por lo que mi duda ahora esta en si debo modificar los parametros URLOK y URLKO que vienen por defecto en redsys.php
$ds_merchant_urlok = tep_href_link('redsys_process.php', '', 'SSL');
$ds_merchant_urlko = tep_href_link('redsys_process.php', '', 'SSL');
¿Creeis que asi se puede solucionar? a alguien mas le ha sucedido que realizan los pagos con tarjeta y estos no se generan en oscommerce????

Gracias por vuestro tiempo

figue
Mensajes: 875
Registrado: hace 8 years
URL de la tienda: www.mueblesdeforja.es
Version oscommerce: 2.3.3
Servidor: Linux
Ubicación: Córdoba
Contactar:

Re: Pago con redsys no genera pedido

Mensaje por figue » hace 5 years

Antes de tocar nada, prueba con este modulo:
http://addons.oscommerce.com/info/6002

En otro tema se dice que funciona bien el tpv de la caixa y este que te digo que es una actualizacion.

tiopardi
Mensajes: 8
Registrado: hace 5 years
URL de la tienda: www.ortored.es
Version oscommerce: 2.3.4
Servidor: Debian

Re: Pago con redsys no genera pedido

Mensaje por tiopardi » hace 5 years

Buenos dias!!!
Graaaaciaa!!voy a instalarlo a ver si este modulo si genera el pedido.
Sino he pensado en instalar ordercheck.
Ya os contare

Un saludo

Neiklot
Mensajes: 4
Registrado: hace 3 years
URL de la tienda: eaefaefawef.es
Version oscommerce: 2.2
Servidor: windows

Re: Pago con redsys no genera pedido

Mensaje por Neiklot » hace 3 years

Hola,

Utilizo Oscommerce 2.0 y Redsys me obliga a cambiar a SHA256, he realizado todos los pasos para instalar y configurar el módulo, sin embargo, el TPV acepta el pago y todo parece funcionar bien, pero mi tienda no procesa el pedido, ni genera el PDF final,

Creo que tiene que ver con checkout_success.php ya que allí no veo que se utilize nada de JSON decode ni nada y quizá con el nuevo TPV deba usarlo.

Muchas gracias por adelantado
Un saludo

tiopardi
Mensajes: 8
Registrado: hace 5 years
URL de la tienda: www.ortored.es
Version oscommerce: 2.3.4
Servidor: Debian

Re: Pago con redsys no genera pedido

Mensaje por tiopardi » hace 3 years

Buenas yo me rendi....pero podriamos retomarlo otra vez aunque falta mucha info bajo mi punto de vista

Neiklot
Mensajes: 4
Registrado: hace 3 years
URL de la tienda: eaefaefawef.es
Version oscommerce: 2.2
Servidor: windows

Re: Pago con redsys no genera pedido

Mensaje por Neiklot » hace 3 years

Pero ahora es obligatorio el cifrado de 256 así que no me puedo rendir! Hay alternativa?

tiopardi
Mensajes: 8
Registrado: hace 5 years
URL de la tienda: www.ortored.es
Version oscommerce: 2.3.4
Servidor: Debian

Re: Pago con redsys no genera pedido

Mensaje por tiopardi » hace 3 years

No tengo ni idea......lo mismo los grandes sabios pueden ayudar

figue
Mensajes: 875
Registrado: hace 8 years
URL de la tienda: www.mueblesdeforja.es
Version oscommerce: 2.3.3
Servidor: Linux
Ubicación: Córdoba
Contactar:

Re: Pago con redsys no genera pedido

Mensaje por figue » hace 3 years

Con un modulo de pago no se pueden ir dando palos de ciego, asi no se soluciona nada.
El modulo esta disponible en la web de redsys y en otro post de este foro, he puesto dicho modulo con algunas correcciones.
Los modulos antiguos tenian este fallo, pero tambien dependia de la configuracion del tpv y del banco que fuese.
El nuevo modulo funciona bien en todos los bancos y cajas, al menos en los mas importantes esta probado.

Responder

Volver a “Contribuciones (Dudas y Soluciones)”